Москва+7 (495) 103-4-103
Заказать звонок
  • Заказать звонок
  • Отложить 0 шт.
  • Сравнить 0 шт.
 12 Дек 2017    Новости ASP24, Ubiquiti, Настройка и установка оборудования , Практика и программирование

В этой статье Вы узнаете, как настроить маршрутизацию Inter-VLAN на EdgeSwitch с помощью Switch Virtual Interfaces (SVI).

Примечания и требования:

Реализация возможна на прошивке EdgeSwitch 1.7.1 + всех моделях EdgeSwitch. Требуется знание интерфейса командной строки (CLI) и базовых сетевые знания.

Оборудование, используемое в этой статье:

Что делаем?

  • Схема сети
  • VLAN-интерфейсы
  • Тестирование и проверка

Схема сети

Ниже показана топология сети, а также интерфейсы для EdgeSwitches (ES) и EdgeRouter (ER).

ER-X

  • eth0 (WAN)
  • eth1 (LAN) - 10.255.12.1/30

ES-8

  • 0/1 (tagged) - VLAN10
  • 0/1 (untagged) - VLAN99
  • 0/2 (untagged) - VLAN20
  • 0/3 (untagged) - VLAN10
  • 0/8 (routed) - 10.255.12.2/30

Точка доступа Unifi AP помечает беспроводную сеть VLAN10. Трафик управления UAP сам по себе будет немаркирован на порту 0/1 и будет размещен в VLAN99 (собственная VLAN). Хост и сервер будут размещены во VLAN10 и VLAN20. Каждый хост получит DHCP-адрес от ES и направит весь трафик через коммутатор ER.

VLAN-интерфейсы

В этом примере EdgeSwitch работает c конфигурацией, которая задана по умолчанию, доступ к управлению получаем через SSH. Первым шагом является создание VLAN и привязка их к конкретным портам (маркированные или немаркированные). Конфигурация будет в основном сосредоточена на ES-Left, поскольку два свича почти идентичны, за исключением портов VLAN и IP-адресов управления.

CLI STEPS: Доступ к интерфейсу командной строки (CLI), получаем используя программу PuTTY для подключения через SSH, Telnet или консоль.

1. Войдите в привилегированный режим.

enable

2. Создайте VLAN и VLAN-интерфейсы (SVIs).

vlan database 
vlan 10,20,99
vlan routing 10 1
vlan routing 20 2
vlan routing 99 3
exit

Примечание. Формат vlan routing . Идентификатор интерфейса не должен соответствовать номеру VLAN и используется для разделения VLAN-интерфейсов во внутренней архитектуре коммутатора.

3. Войдите в режим настройки.

configure

4. Назначьте порты в VLAN, созданные выше.

Конфигурация ниже: отключает порт 0/2 для VLAN20 и 0/3 для VLAN10 (pvid). Порт 0/1 будет помечен для VLAN10 (маркированный) с VLAN99 в качестве собственной VLAN (pvid). После этого ненужные VLAN исключаются из "сети"

interface 0/1
description UAP
vlan tagging 10
vlan pvid 99
vlan participation exclude 1,20
vlan participation include 10,99
exit

interface 0/2
description Server
vlan pvid 20
vlan participation exclude 1,10,99
vlan participation include 20
exit

interface 0/3
description Host
vlan pvid 10
vlan participation exclude 1,20,99
vlan participation include 10
exit

4. Включите функцию аплинк на (0/8) порту и назначьте IP-адрес.

interface 0/8
description ER-X
routing
ip address 10.255.12.2 255.255.255.252
exit

5. Свяжите SVI с IP-адресами и включите маршрутизацию.

interface vlan 10
ip address 10.0.10.2 255.255.255.0
routing
exit

interface vlan 20
ip address 10.0.20.2 255.255.255.0
routing
exit

interface vlan 99
ip address 10.0.99.2 255.255.255.0
routing
exit

6. Необходимо включить функцию глобальной маршрутизации и создать маршрут по умолчанию для ER.

ip routing
ip route 0.0.0.0 0.0.0.0 10.255.12.1

Примечание: рекомендуется создать маршрут по умолчанию (и все другие маршруты), используя IP маршрут вместо заявленного . Последняя команда предназначена для EdgeSwitch, которые работают только в режиме 2–го уровня без каких-либо дополнительных функций маршрутизации.

7. (Необязательно) Разрешить глобальные услуги DHCP.

service dhcp

8. (Необязательно) Исключить IP-адреса, которые не должны быть назначены сервером DHCP.

ip dhcp excluded-address 10.0.10.0 10.0.10.10
ip dhcp excluded-address 10.0.20.0 10.0.20.10
ip dhcp excluded-address 10.0.99.0 10.0.99.10

9. (Необязательно) Создайте пулы DHCP.

ip dhcp pool VLAN10
lease 0 12 0
dns-server 10.0.20.11
default-router 10.0.10.2
network 10.0.10.0 255.255.255.0
exit

ip dhcp pool VLAN20
lease 0 12 0
dns-server 10.0.20.11
default-router 10.0.20.2
network 10.0.20.0 255.255.255.0
exit

ip dhcp pool VLAN99
lease 0 12 0
dns-server 10.0.20.11
default-router 10.0.99.2
network 10.0.99.0 255.255.255.0
exit

Примечание. В этом примере сервер в 10.0.20.11 предоставляет службы DNS для всех VLAN.

10. Вернитесь в привилегированный режим и запишите изменения в конфигурацию запуска.

exit
write memory
(Альтернативній вариант) GUI STEPS: Доступ к веб-серверу управления коммутатором (GUI).

1. Создайте VLAN. Basic > VLAN > VLAN Wizard > Add VLAN

Enter 10,20,99 and select 'Add'

2. Назначьте порты VLAN, созданные выше, с помощью мастера.

Port 0/1: Excluded (E) for VLAN1 / VLAN20
Port 0/1: Untagged (U) for VLAN99
Port 0/1: Tagged (T) for VLAN10

Port 0/2: Excluded (E) for VLAN1 / VLAN10 / VLAN99
Port 0/2: Untagged (U) for VLAN20

Port 0/3: Excluded (E) for VLAN1 / VLAN20 / VLAN99
Port 0/3: Untagged (U) for VLAN10

3. Создайте SVI и включите функцию IP-маршрутизации. Routing > IP > Interface Configuration

Type: VLAN
VLAN: VLAN 10
Routing Mode: Enable
Admin Mode: Enable
IP Address Configuration Method: Manual
IP Address: 10.0.10.2
Subnet Mask: 255.255.255.0

Type: VLAN
VLAN: VLAN 20
Routing Mode: Enable
Admin Mode: Enable
IP Address Configuration Method: Manual
IP Address: 10.0.20.2
Subnet Mask: 255.255.255.0

Type: VLAN
VLAN: VLAN 99
Routing Mode: Enable
Admin Mode: Enable
IP Address Configuration Method: Manual
IP Address: 10.0.99.2
Subnet Mask: 255.255.255.0

4.Необходимо включить глобальную функцию маршрутизации и создать маршрут по умолчанию в ER.

Routing Mode: Enabled

Routing > Router > Configured Routes > Add

Route Type: Static
Network Address: 0.0.0.0
Subnet Mask: 0.0.0.0
Next Hop IP Address: 10.255.12.1
Preference: 1

5. (Необязательно) Глобально включить службы DHCP. System > Advanced Configuration > DHCP Server > Global

Admin Mode: Enable

6. (Необязательно) Создайте пулы DHCP. System > Advanced Configuration > DHCP Server > Pool Summary > Add

Pool Name: VLAN10
Type of Binding: Dynamic
Network Base Address: 10.0.10.0
Network Mask: 255.255.255.0
Range Start: 10.0.10.11
Range Stop: 10.0.10.255
Lease Expiration: Enable
Lease Duration: 12 Hours
Default Router Address 10.0.10.2
DNS Server Address 1: 10.0.20.11

Pool Name: VLAN20
Type of Binding: Dynamic
Network Base Address: 10.0.20.0
Network Mask: 255.255.255.0
Range Start: 10.0.20.11
Range Stop: 10.0.20.255
Lease Expiration: Enable
Lease Duration: 12 Hours
Default Router Address 10.0.20.2
DNS Server Address 1: 10.0.20.11

Pool Name: VLAN99
Type of Binding: Dynamic
Network Base Address: 10.0.99.0
Network Mask: 255.255.255.0
Range Start: 10.0.99.11
Range Stop: 10.0.99.255
Lease Expiration: Enable
Lease Duration: 12 Hours
Default Router Address 10.0.99.2
DNS Server Address 1: 10.0.99.11

Тестирование и проверка

После настройки портов и VLAN проверьте состояние соединений/точек, используя следующие команды:

1. Состояние порта VLAN интерфейсов коммутатора:

show interfaces switchport general 
Intf PVID Ingress Acceptable Untagged Tagged Forbidden Dynamic
Filtering Frame Type Vlans Vlans Vlans Vlans
--------- ----- ---------- ---------- --------- --------- --------- ---------
0/1 99 Disabled Admit all 99 10 1,20
0/2 20 Disabled Admit all 20 1,10,99
0/3 10 Disabled Admit all 10 1,20,99

show interfaces switchport 0/1
VLAN Membership Mode: General
General Mode PVID: 99
General Mode Untagged VLANs: 99
General Mode Tagged VLANs: 10
General Mode Forbidden VLANs: 1,20

show interfaces switchport 0/2
VLAN Membership Mode: General
General Mode PVID: 20
General Mode Untagged VLANs: 20
General Mode Tagged VLANs:
General Mode Forbidden VLANs: 1,10,99

show interfaces switchport 0/3
VLAN Membership Mode: General
General Mode PVID: 10
General Mode Untagged VLANs: 10
General Mode Tagged VLANs:
General Mode Forbidden VLANs: 1,20,99

2. Состояние маршрутизируемого интерфейса и SVI:

show ip interface 0/8
Routing interface status....................... Up
Primary IP address............................. 10.255.12.2/255.255.255.252
Method......................................... Manual
Routing Mode................................... Enable
Administrative Mode............................ Enable
Active State................................... Active
Encapsulation Type............................. Ethernet
IP MTU......................................... 1500

show ip interface brief
Interface State IP Address IP Mask TYPE Method
---------- ----- --------------- --------------- --------------- ------
0/8 Up 10.255.12.2 255.255.255.252 Primary Manual
vlan 10 Up 10.0.10.2 255.255.255.0 Primary Manual
vlan 20 Up 10.0.20.2 255.255.255.0 Primary Manual
vlan 99 Up 10.0.99.2 255.255.255.0 Primary Manual

show ip route
Route Codes: C - Connected, S - Static
Default Gateway is 10.255.12.1

S 0.0.0.0/0 [1/0] via 10.255.12.1, 00h:04m:36s, 0/8
C 10.0.10.0/24 [0/0] directly connected, 4/1
C 10.0.20.0/24 [0/0] directly connected, 4/2
C 10.0.99.0/24 [0/0] directly connected, 4/3
C 10.255.12.0/30 [0/0] directly connected, 0/8

3. Глобальные параметры DHCP и пулы (если они настроены):

show ip dhcp global configuration
Service DHCP................................... Enable
Number of Ping Packets......................... 2
Excluded Address............................... 10.0.10.0 to 10.0.10.10
                                                10.0.20.0 to 10.0.20.10
                                                10.0.99.0 to 10.0.99.10
Conflict Logging............................... Enable
Bootp Automatic................................ Disable

show ip dhcp pool configuration all
Pool: VLAN10
Pool Type...................................... Dynamic
Network........................................ 10.0.10.0 255.255.255.0
Lease Time..................................... 0 days 12 hrs 0 mins
DNS Servers.................................... 10.0.20.11
Default Routers................................ 10.0.10.2

Pool: VLAN20
Pool Type...................................... Dynamic
Network........................................ 10.0.20.0 255.255.255.0
Lease Time..................................... 0 days 12 hrs 0 mins
DNS Servers.................................... 10.0.20.11
Default Routers................................ 10.0.20.2

Pool: VLAN99
Pool Type...................................... Dynamic
Network........................................ 10.0.99.0 255.255.255.0
Lease Time..................................... 0 days 12 hrs 0 mins
DNS Servers.................................... 10.0.20.11
Default Routers................................ 10.0.99.2

show ip dhcp binding
IP address Hardware Address Lease Expiration Type
--------------- ----------------- ----------------- ------------------
10.0.10.11 80:2a:a8:8b:bd:01 00:11:51 Automatic (Phone)
10.0.10.12 80:2a:a8:00:80:dc 00:11:46 Automatic (Host)
10.0.20.11 80:2a:a8:a5:a8:99 00:11:50 Automatic (Server)
10.0.99.11 80:2a:a8:99:92:d5 00:11:50 Automatic (UAP)

4. Проверьте доступность самих хостов:

Server> tracert -d 10.255.12.1
Tracing route to 10.255.12.1 over a maximum of 30 hops

1 1 ms 1 ms 1 ms 10.0.20.2
2 1 ms <1 ms <1 ms 10.255.12.1

Server> tracert -d 10.0.10.11
Tracing route to 10.0.10.11 over a maximum of 30 hops

1 1 ms 1 ms 1 ms 10.0.20.2
2 <1 ms <1 ms <1 ms 10.0.10.11

Server> tracert -d 10.0.99.11
Tracing route to 10.0.99.11 over a maximum of 30 hops

1 1 ms 1 ms 2 ms 10.0.20.2
2 <1 ms <1 ms <1 ms 10.0.99.11

Host> tracert -d 10.255.12.1
Tracing route to 10.255.12.1 over a maximum of 30 hops

1 1 ms 1 ms 1 ms 10.0.10.2
2 1 ms <1 ms <1 ms 10.255.12.1

Host> tracert -d 10.0.20.11
Tracing route to 10.0.20.11 over a maximum of 30 hops

1 1 ms 1 ms 1 ms 10.0.10.2
2 4 ms 3 ms 6 ms 10.0.20.11

Host> tracert -d 10.0.99.11
Tracing route to 10.0.99.11 over a maximum of 30 hops

1 1 ms 1 ms 1 ms 10.0.10.2
2 2 ms 1 ms 1 ms 10.0.99.11

Авторский перевод "EdgeSwitch - VLANs and Inter-VLAN Routing (Layer 3 Switching)"