Меню
Контакты
109147, Москва, ул.Воронцовская, 35Б, корп.2 офис.11, 4 этаж
Пн-Пт: с 9-00 до 19-00   Сб-вс: выходной
Интернет-магазин
сетевого оборудования
Москва +7 (495) 103-41-03 +7 (915) 420-28-94
109147, Москва, ул.Воронцовская, 35Б, корп.2 офис.11, 4 этаж
Пн-Пт: с 9-00 до 19-00   Сб-вс: выходной
Заказать звонок

Создание домашней сети на базе устройств MikroTik: Часть 2 — Настройка hAP ac

 02 Июнь 2018    MikroTik, Настройка и установка оборудования , Scripts

Здравствуйте и Добро пожаловать на цикл статей по организации единой локальной сети!

Мы обозначили схему, которую нам необходимо реализовать.
Начнем мы с базового роутера MikroTik hAP ac.
Предварительно перед настройкой я заказал услугу Публичный статический IP адрес! Это важно, без него туннели будет сложно построить(DDNS)
Предположим провайдер назначил нам IP = 98.76.54.32 (Взят для примеров)

В данной статье я покажу основные настройки, чтобы роутер мог получать интернет и раздавать его клиентам.
Статья получится достаточно большая, поэтому запаситесь терпением )))
Настройка VPN будет в отдельной статье.

ВАЖНО!!!
Компания MikroTik довольно активно изменяет и добавляет новый функционал в свои изделия. От этого меняются версии прошивок и в них бывают настолько серьезные изменения, что статьи в некоторых местах теряют свою актуальность. Так вот данная статья написана для прошивки 6.39.3 из ветки Bugfix.
Именно ветка Bugfix стабильнее всего и реже всего обновляется. Я предпочитаю стабильность, вместо каких-то новых фич, которые еще не до конца протестированы.

Подключим роутер к ПК/Ноутбук через порт 2, а кабель провайдера в порт 1.

hap-ac-port2

Синим — Internet, Красным — Локальный

На ПК для сетевого интерфейса устанавливаем статический IP 192.168.88.5 и маску сети 255.255.255.0
Это нужно если у роутера отсутствует IP адрес.

Открываем утилиту WinBox (Подробнее: Тут и Тут). Сбрасываем все заводские настройки, они нам не понадобятся!

reset-configuration

Сброс настроек

Консольно:

/system reset-configuration no-defaults=yes skip-backup=yes

Подтверждаем сброс настроек.

После этой процедуры, у роутера не будет IP адреса, поэтому подключаемся по MAC адресу.
Все настройки будут сброшены, начнем настройку:

1. Настроим проводные интерфейсы
Меню настройки интерфейсов:

interfaces

Меню интерфейсов

Консольно:

/interface

Все интерфейсы RJ45 входят в один свич(switch1) поэтому нам нужно отделить порт для провайдера, и порты для локальных соединений. Отдельно у нас еще стоят два Wi-Fi интерфейса и разъем SFP.
Выбираем интерфейс ether1 и переименовываем его в WAN

ether1-rename

Меняем имя порта ether1

Консольно:

/interface ethernet set [find default-name=ether1] name=WAN

Выбираем интерфейс ether2 и переименовываем его в LAN1-Master
Т.к все сетевые порты у нас находятся в свиче, мы можем сделать один из портов ведущим(Мастер порт), а остальные ведомыми(Слейв порты). По сути получится, как будто каждый из портов это один и тот же порт.

ether2-rename

Меняем имя порта ether2

Консольно:

/interface ethernet set [find default-name=ether2] name=LAN1-Master

Остальные ether3, ether4 и ether5 переименовываем соответствующе LAN2-Slave, LAN3-Slave, LAN4-Slave и назначаем им Мастер портом — порт LAN1-Master

ether3-rename

Для остальных делаем по аналогии

Консольно:

/interface ethernet set [find default-name=ether3] name=LAN2-Slave master-port=LAN1-Master
/interface ethernet set [find default-name=ether4] name=LAN3-Slave master-port=LAN1-Master
/interface ethernet set [find default-name=ether5] name=LAN4-Slave master-port=LAN1-Master

Отключим SFP порт, лично мне он ни к чему, просто, как приятный бонус. Вдруг потом пригодится.
Вы же можете докупить SFP модуль для обычного RJ-45 порта и использовать его для подключения кабеля провайдера. Вы ведь помните, что он на отдельной шине 1Gbit ))

disable-interface

Кнопка выключения

Консольно:

/interface ethernet disable sfp1

С проводными соединениями разобрались, перейдем далее…

2. Настроим Wi-Fi соединения
В модели hAP ac присутствует два вида Wi-Fi. Это 2.4GHz и 5GHz частоты. Соответственно в роутере мы имеем два Wi-Fi интерфейса — wlan1 и wlan2
Зайдя в настройки каждого, можно определить, какой из них какой.
2.4GHz

wifi-24

Модуль 2.4GHz

5GHz
wifi-5

Модуль 5GHz

Консольно:

/interface wireless print

Для начала настроим профиль авторизации для наших Wi-Fi интерфейсов:

wireless

Wi-Fi интерфейсы и параметры

Настраиваем базовый профиль или добавляем свой

wireless-security

WPA2 Pre-Shared Key — это и будет Ваш пароль к Wi-Fi

Консольно:

/interface wireless security-profiles set default mode=dynamic-keys authentication-types=wpa2-psk unicast-ciphers=aes-ccm group-ciphers=aes-ccm wpa2-pre-shared-key="12345678" management-protection=disabled

Теперь можно переходить к настройке самих интерфейсов Wi-Fi. Настроек много, глаза разбегаются, но ничего страшного, каждый пункт важен.
Начнем с интерфейса 2.4GHz.

wifi24-general

Вкладка General: меняем имя интерфейса — LAN-wifi24ghz и активируем расширенный режим!!

wifi24-wireless

Достаточно много настроек

Давайте пробежимся по параметрам Mode — Режим работы модуля Wi-Fi. Выбираем режим для работы как точки доступа в режиме моста.
Band — Стандарт Wi-Fi соединения. Есди у Вас нет старых ноутбуков или иных устройств работающих на стандартах b или g выбирайте максимально доступный. Лучше всего если у Вас нет устройств с b или g, выбирайте режим 2GHz-only-N.
Даже если у Вас нет таких устройств, но Вы оставили режим B/G/N, такие устройства могут быть у Ваших соседей и тогда у Вас «просядет» вся Wi-Fi сеть до самого низкого стандарта. Будьте внимательны!
Channel Width — Ширина канала.
Frequency — Рабочая частота.
SSID — Имя Вашей Wi-Fi сети
Radio Name — Имя радио интерфейса, будет отображаться в таблице регистрации при подключении по Wi-Fi к другому микротику. В принципе не нужен, работает только на Микротиках.
Wireless Protocol — Выбирайте 802.11 т.к. остальные это протоколы Микротика. unspecified использовался раньше в RouterOS 3 и 4 версий.
Security Profile — Выбираем наш профиль шифрования с паролями к Wi-Fi.
WPS Mode — Отключаем WPS мы не будем им пользоваться.
Frequency Mode — Частотный режим. Всего три режима (для конкретной страны, ручное назначение, суперканал). В принципе не важно, что Вы выберите, главное ничего не нарушать. И чтобы не нарушать законодательство нужно выбрать режим регулируется страной и ниже свою страну.
Country — Ограничивает доступные диапазоны, частоты и максимальную мощность передачи для каждой частоты в зависимости от страны.
Antenna Gain — Коэффициент усиления антенны в дБи, используемый для расчета максимальной мощности передачи в соответствии с национальными правилами.
WMM Support — Указывает, следует ли включать WMM.
Bridge Mode — Активируем режим моста для интерфейса.
Default Authenticate — Позволяем клиентам авторизовываться.
Default Forward — Возможность общения клиентов между собой.
Multicast Helper — Этот параметр можете выбрать самостоятельно. Если У Вас в сети используется IPTV по Wi-Fi, тогда без этой настройки не обойтись. Если ничего подобного нет, тогда можете отключить.

wifi24-advanced

Тут настроек не много, но они важные

Distance — Как долго ждать подтверждения одноадресных фреймов, прежде чем считать передачу неудачной. Если используем в небольшом помещении, ставим indoors, если на улице или в цеху, то dynamic.
Adaptive Noise Immunity — Это свойство действует только для карт на базе чипсета Atheros.

wifi24-ht

Выбираем антенны для работы

Отключаем все. Этими настройками мы пользоваться не будем.

wifi24-nstreme

Специфические настройки для nstreme

wifi24-tx-power

Настройка мощности передатчиков

Я предпочитаю самостоятельно устанавливать мощность передатчиков. Но не ухожу за рамки законодательства. Для России лучше выбирать значения 15-17.
На практике я понял, что разницы для квартиры особой нет, можно оставить и базовые значения, чтобы роутер самостоятельно настраивал мощность. Все и так работает, как часы!

Консольно:

/interface wireless set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode band=2ghz-onlyn basic-rates-b="" channel-width=20/40mhz-Ce country=romania disabled=no distance=indoors frequency=auto frequency-mode=regulatory-domain hw-protection-mode=rts-cts mode=ap-bridge multicast-helper=full name=LAN5-wifi24ghz radio-name=POINT24_1 ssid=POINT24GHZ supported-rates-b="" wireless-protocol=802.11 wmm-support=enabled wps-mode=disabled
/interface wireless nstreme set LAN5-wifi24ghz enable-polling=no

С интерфейсом 2.4GHz закончили.

Переходим к интерфейсу 5GHz
Сразу напомню, что в ПК я использую PCI модуль Wi-Fi ASUS PCE-AC66. Он имеет три антенны и позволяет работать с AC стандартом.
5GHz еще может работать со стандартом N, но в этом случае скорости ~800-900 Мбит/сек Вам не светят.
Поэтому настройки у меня будут под чистый AC стандарт. Поехали…

wifi5-general

Меняем имя интерфейса, MTU, и убеждаемся, что ARP включено.

wifi5-wireless

Также большой список в Advanced режиме

В принципе все настройки идентичны тем, что устанавливаются для 2.4GHz. Но есть ряд особенностей!
Channel Width — С этими параметрами пришлось поиграть, чтобы подобрать верный диапазон и частоту на которых будет работать PCE-AC66.
Frequency — Частота для канала, задал в ручную т.к. канал не забит соседями ))

Данные параметры оказались самые стабильные для использования с PCE-AC66 от Асус.

wifi5-advanced

Тоже самое, что и для 2.4GHz

wifi5-ht

Аналогично 2.4GHz

Аналогично 2.4GHz

wifi5-txpower

Аналогично 2.4GHz

Консольно:

/interface wireless set [ find default-name=wlan2 ] adaptive-noise-immunity=ap-and-client-mode band=5ghz-onlyac channel-width=20/40/80mhz-Ceee country=romania disabled=no distance=indoors frequency=auto frequency-mode=regulatory-domain hw-protection-mode=rts-cts mode=ap-bridge multicast-helper=full name=LAN6-wifi5ghz radio-name=POINT5_1 ssid=POINT5GHZ wireless-protocol=802.11 wmm-support=enabled wps-mode=disabled
/interface wireless nstreme set LAN6-wifi5ghz enable-polling=no

Закончили с интерфейсом 5GHz.

3. Создадим сетевой мост всех наших интерфейсов
Сетевой мост будет служить основным интерфейсом, который соберет в себе все наши локальные интерфейсы. Т.е. нужно добавить к новому сетевому мосту все нужные интерфейсы.
Также мы помним, что мы сделали мастер порт и часть портов привязали к нему, соответственно все второстепенные порты добавлять не нужно.

В этом меню можно создавать сетевые мосты

Создадим сам сетевой мост. Назовем его LAN-Bridge

bridge-add

Создаем сетевой мост

Консольно:

/interface bridge add name="LAN-Bridge" comment="LAN" mtu=1500 arp=proxy-arp

Начнем добавлять порты.

bridge-port-add

И так для каждого нужного порта

Нам нужно добавить порты:
LAN1-Master
LAN5-wifi24ghz
LAN6-wifi5ghz

 

Консольно:

/interface bridge port
add interface=LAN1-Master bridge=LAN-Bridge
add interface=LAN5-wifi24ghz bridge=LAN-Bridge
add interface=LAN6-wifi5ghz bridge=LAN-Bridge

В момент добавления интерфейса LAN1-Master Вас может отключить от роутера, в этом нет ничего страшного, просто подключаемся снова.

4. Разрешим нашему роутеру обрабатывать DNS

dns

Разрешаем обработку DNS запросов

Консольно:

/ip dns set allow-remote-requests=yes cache-size=4096

5. Подключение к провайдеру
У меня Интернет провайдер предоставляет интернет по DHCP. Т.е. необходимо настроить DHCP клиент на порт в который вставлен кабель провайдера (WAN)

ip-dhcpclient

Находим нужное меню и добавляем новое правило

Указываем нужный интерфейс.

ip-dhcpclient-add

Параметров не много

В столбце IP Address мы должны увидеть свой статический IP от провайдера. Вы же помните, что для этого роутера нужно подключить Статический IP!!!

Консольно:

/ip dhcp-client add interface=WAN add-default-route=yes disabled=no default-route-distance=1 use-peer-dns=yes use-peer-ntp=yes

6. Доступ в интернет
Для того, чтобы наши клиенты могли выходить в сеть интернет, нам необходимо указать, через какой интерфейс они будут это делать.
Эти настройки делаются через Межсетевой экран (Firewall)

ip-firewall

Переходим в межсетевой экран

ip-firewall-add-1

Указываем основные параметры

ip-firewall-add-2

Указываем последнее правило и жмем OK

В принципе этого достаточно, чтобы на роутере уже появился интернет. Но у клиентов его не будет т.к. еще нет IP адреса и локального DHCP сервера.

Консольно:

/ip firewall nat add chain=srcnat out-interface=WAN action=masquerade

7. IP адрес роутера
Теперь назначим нашему роутеру IP адрес.
Мы определили, что в Локации 1 будет следующий разброс:
IP адрес роутера: 192.168.88.1
IP адреса для клиентов: 192.168.88.5 — 192.168.88.29
24 адреса должно хватить для всех устройств в квартире, даже с избытком.

ip-addresses

Переходим в меню IP адресов

ip-addresses-add

Добавляем IP адрес для нашего сетевого моста

Так мы указываем, что IP адрес 192.168.88.1 привязать к интерфейсу LAN-Bridge.

Консольно:

/ip address add address=192.168.88.1/24 interface=LAN-Bridge

8. DHCP Сервер для локальных клиентов
Для того, чтобы наши клиенты могли подключаться к нашему роутеру и получать от него IP адреса и другие параметры, необходимо настроить DHCP сервер.
Первоначально укажем Pool IP адресов

ip-pool

Переходим в меню

ip-pool-add

Добавляем обозначенный диапазон

Теперь добавляем сам DHCP сервер

Переходим к добавлению DHCP

ip-dhcpserver-add

Задаем настройки DHCP сервера

Осталось еще указать для какой сети и какие дополнительные параметры будут получать

подключенные клиенты.
ip-dhcpserver-networks

Указываем дополнительные параметры

Каждый подключенный клиент будет получать от DHCP сервера набор параметров:

Шлюз и DNS — В нашем случае и тем и другим будет выступать сам роутер.

 

Консольно:

/ip pool add name=LAN-Pool ranges=192.168.88.5-192.168.88.29
/ip dhcp-server add name=DHCP-Server interface=LAN-Bridge lease-time=12h address-pool=LAN-Pool bootp-support=dynamic bootp-lease-time=lease-time add-arp=yes authoritative=yes
/ip dhcp-server network add address=192.168.88.0/24 gateway=192.168.88.1 netmask=24 dns-server=192.168.88.1

В принципе уже можно подключать устройства по Wi-Fi и любые другие, уже должен работать интернет.
Для затравки ))))

wireless_reg

Тут важно понимать, что это не практические скорости, а расчитанные роутером. Эти параметры меняются при активном использовании Wi-Fi

На этом закончим статью, остальные настройки рассмотрим позже )) Сама статья получилась достаточно большая и если Вы дочитали до конца Вы определенно молодцы!!!
Продолжение:
Создание домашней сети на базе устройств MikroTik: Часть 3 — Настройка RB750gr3 hEX

UPD: 09.02.2018
Изменены настройки для Wi-Fi 2.4GHz и 5GHz на основании опыта эксплуатации.

UPD: 20.03.2018
Исправил ошибку отсутствия ручного ввода MTU в сетевой мост LAN-Bridge. Если этого не сделать, в статье по созданию EoIP туннеля меняется MTU сетевого моста. Т.к. Root Port-ом становится интерфейс EoIP туннеля.

UPD: 08.04.2018
Найдена проблема: radar detected on
Сработал радар детектор. Вернее сработала система DFS (Dynamic Frequency Selection — динамический выбор частоты)
В роутере это выглядит так. Смотрим лог:

hapac-1

Т.е сработал радарный детектор на частоте 5260 МГц. Радарные импульсы довольно трудно обнаружить, потому что они довольно быстрые (каждый импульс длится около половины микросекунды) и может присутствовать на очень низких уровнях мощности (от -62 до -64 дБмВт), но наш Роутер справился ))
А проблемой является постоянное отключение клиентов от точки 5 ГГц!!!
Это не хорошо, и я решил зафиксировать частоту на самой низкой в 5180 МГц

hapac-2 

Понаблюдаю работу в этом режиме. Но на первый взгляд, канал стал работать стабильнее.

Источник