Москва+7 (495) 103-4-103
Заказать звонок
  • Заказать звонок
  • Отложить 0 шт.
  • Сравнить 0 шт.
 28 Окт 2016    MikroTik, Практика и программирование

И так: как на RB952Ui-5ac2nD сделать более одной группы коммутации?

Обходим ограничение чипа Atheros8227

Сформулируем проблему: есть домашний интернет с телевидением, но на приставку нужно дать кабель не после нашего NAT, а до него. Обычно провайдер предлагает маленький коммутатор до вашего роутера (какой кошмар, столько ненужных устройств!), или если роутер умеет, вы создаете на нем мост из двух портов, которые отдаете внешней сети (входящий кабель+приставка ТВ). Но, вышеозначенный Mikrotik не умеет две группы коммутации, и потому, приходится делать софтовый bridge (а хочется отдать это в «железо»).

Теперь реализация: объединим все порты в группу коммутации (выставим мастер порт):

/interface ethernet set ether1 master-port=ether2-master

 Mikrotik Switch Chip

Аналогично для всех остальных.

Теперь возьмем, и создадим два VLAN, один для внешней сети (к примеру VID:1), и для внутренней (VID:2):


/interface vlan
add interface=ether2-master \
    name=ext vlan-id=1
add interface=ether2-master \
   name=V_LAN vlan-id=2

 Mikrotik Switch Chip


/interface ethernet switch port
set ether1 default-vlan-id=1 vlan-header=always-strip vlan-mode=secure
set ether2-master default-vlan-id=1 vlan-header=always-strip vlan-mode=secure
set ether3 default-vlan-id=2 vlan-header=always-strip vlan-mode=secure
set ether4 default-vlan-id=2 vlan-header=always-strip vlan-mode=secure
set ether5 default-vlan-id=2 vlan-header=always-strip vlan-mode=secure
set switch1-cpu default-vlan-id=2 vlan-header=add-if-missing vlan-mode=secure

 Mikrotik Switch Chip

Теперь создаем таблицу VLAN:

/interface ethernet switch vlan
add ports=ether1,ether2-master,ether3,ether4,ether5,switch1-cpu switch=switch1 vlan-id=1
add ports=ether1,ether2-master,ether3,ether4,ether5,switch1-cpu switch=switch1 vlan-id=2

Mikrotik Switch Chip 

Все, теперь чип коммутации сделает нужную нам работу.

© MagicGTS