Москва+7 (495) 103-4-103
Заказать звонок
  • Заказать звонок
  • Отложить 0 шт.
  • Сравнить 0 шт.
 13 Июл 2016    MikroTik, Практика и программирование

Для того чтобы ограничить скорость торрентов - сначала требуется промаркировать (пометить) торрент-трафик.

Для маркировки соединений р2р (peer-to-peer), к которым и относится торрент, непосредственно в в настройках есть уже параметр p2p=all-p2p но это работает не для всех торрент-клиентов.

Применим более широкую маркировку входящих торрент-пакетов по протоколам, портам и размерам пакета:

Открываем winbox и подключаемся к нашему маршрутизатору, нажимаем кнопку New Terminal и в открывшемся окне вводим следующие комманды

Для начала промакируем общий трафик р2р

/ip firewall mangle 
add action=mark-packet chain=prerouting in-interface=WAN new-packet-mark=all-torrent p2p=all-p2p passthrough=no

Затем промаркируем соединения по протоколу tcp

/ip firewall mangle   
add action=mark-packet chain=prerouting in-interface=WAN new-packet-mark=all-torrent \
passthrough=no protocol=tcp src-port=1024-65535 packet-size=576 
add action=mark-packet chain=prerouting in-interface=WAN new-packet-mark=all-torrent \
passthrough=no protocol=tcp src-port=1024-65535 packet-size=1240 
add action=mark-packet chain=prerouting in-interface=WAN new-packet-mark=all-torrent \
passthrough=no protocol=tcp src-port=1024-65535 packet-size=1330 
add action=mark-packet chain=prerouting in-interface=WAN new-packet-mark=all-torrent \
passthrough=no protocol=tcp src-port=1024-65535 packet-size=1400 
add action=mark-packet chain=prerouting in-interface=WAN new-packet-mark=all-torrent \
passthrough=no protocol=tcp src-port=1024-65535 packet-size=1460 

Маркируем соединения по протоколу udp

/ip firewall mangle   
add action=mark-packet chain=prerouting in-interface=WAN new-packet-mark=all-torrent \
passthrough=no protocol=udp src-port=1024-65535 packet-size=398 
add action=mark-packet chain=prerouting in-interface=WAN new-packet-mark=all-torrent \
passthrough=no protocol=udp src-port=1024-65535 packet-size=748 
add action=mark-packet chain=prerouting in-interface=WAN new-packet-mark=all-torrent \
passthrough=no protocol=udp src-port=1024-65535 packet-size=1430 
add action=mark-packet chain=prerouting in-interface=WAN new-packet-mark=all-torrent \
passthrough=no protocol=udp src-port=1024-65535 packet-size=1448 
add action=mark-packet chain=prerouting in-interface=WAN new-packet-mark=all-torrent \
passthrough=no protocol=udp src-port=1024-65535 packet-size=1466 

Теперь, когда соединения промаркированы, добавим на самый верх в Simple Queue одно правило , указав Packet Marks - all-torrent и желаемую Tx-скорость, например, 7M. Где 7M - это общая скорость 7 Мбит/с на всех клиентов, использующих торрент.

В Simple Queue можно также каждому клиенту указать скорость на торрент в отдельности, т.е. для каждого IP-адреса создать дополнительную запись.

Источник: https://wiki.netair.by/wiki/settings/howto_mark_torrent