Москва+7 (495) 103-4-103
Заказать звонок
  • Заказать звонок
  • Отложить 0 шт.
  • Сравнить 0 шт.
 26 Мар 2017    MikroTik, Scripts

Иногда нужно симитировать плохое соединение с Интернет. Причины могут быть разные, например "вредный пользователь".

WiKi Mikrotik так объясняет эту опцию.

Опция Random в Firewall Mikrotik

По факту, опция указывает в процентном соотношении количество пакетов для которых будет применяться данное правило.

Для примера создадим правило, которое будет имитировать потерю пинга на сервер 8.8.8.8 в 20%.

Опция Random в Firewall Mikrotik

Опция Random в Firewall Mikrotik

Опция Random в Firewall Mikrotik

Само правило:

/ip firewall filter
add action=drop chain=forward dst-address=8.8.8.8 protocol=icmp random=20

Результат:

Опция Random в Firewall Mikrotik

Аналогично можно блокировать, допустим, доступ на веб-сервисы, или вообще на все tcp-соединения.

/ip firewall filter
add action=reject chain=forward dst-port=80 protocol=tcp random=50 reject-with=icmp-network-unreachable src-address=192.168.88.27

Представленное правило блокирует 50 процентов запросов с ip 192.168.88.27 на 80 порт.

Используемый материал